cubicweb_seda/makefile
author Denis Laxalde <denis@laxalde.org>
Tue, 06 Feb 2018 08:56:33 +0100
changeset 2935 d06b9c2459cb
parent 2388 b8fc498d0227
permissions -rw-r--r--
[pkg] Require cubicweb >= 3.25.4 And drop monkeypatch now in this version.


all:
	python xsd2yams.py > schema/seda2.py
	python xsd2uicfg.py | grep -v 'unsupported merge' | grep -v 'extending cards' > views/uicfg.py
	python xsd2entities.py | grep -v 'unsupported merge' | grep -v 'extending cards' > entities/generated.py

lcsv:
	python xsd2concepts.py migration/data