[pkg] prepare 1.9.7 (on stable branch) stable cubicweb-blog-centos-version-1.9.7-1 cubicweb-blog-debian-version-1.9.7-1 cubicweb-blog-version-1.9.7
authorDavid Douard <david.douard@logilab.fr>
Mon, 05 Aug 2013 11:15:44 +0200
branchstable
changeset 303 59c4d5c8b1c8
parent 298 e9526bfa5802 (current diff)
parent 302 370a454eb55b (diff)
child 304 2e5c49312081
child 309 611a9affe30f
[pkg] prepare 1.9.7 (on stable branch)
__pkginfo__.py
cubicweb-blog.spec
debian/changelog
--- a/.hgtags	Thu Mar 21 15:40:29 2013 +0100
+++ b/.hgtags	Mon Aug 05 11:15:44 2013 +0200
@@ -30,5 +30,6 @@
 761ed24bb9459cdad7d0304447b864a588a3bffb cubicweb-blog-debian-version-1.9.5-1
 dd5712e2ba6512ff34d0b3276788db3caa4b00a1 cubicweb-blog-version-1.9.4
 dd5712e2ba6512ff34d0b3276788db3caa4b00a1 cubicweb-blog-version-1.9.4-1
+6500dc13ddbf64ed81f9dabfdb387f0013928d97 cubicweb-blog-centos-version-1.9.6-1
 9cf47f94c8e3e903279a9d4578c3b8cf8396f909 cubicweb-blog-version-1.9.6
 e9c88c575ec0f1426bf75744b0811d27ae19110b cubicweb-blog-debian-version-1.9.6-1
--- a/__pkginfo__.py	Thu Mar 21 15:40:29 2013 +0100
+++ b/__pkginfo__.py	Mon Aug 05 11:15:44 2013 +0200
@@ -4,7 +4,7 @@
 modname = 'blog'
 distname = "cubicweb-%s" % modname
 
-numversion = (1, 9, 6)
+numversion = (1, 9, 7)
 version = '.'.join(str(num) for num in numversion)
 
 license = 'LGPL'
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/cubicweb-blog.spec	Mon Aug 05 11:15:44 2013 +0200
@@ -0,0 +1,46 @@
+# for el5, force use of python2.6
+%if 0%{?el5}
+%define python python26
+%define __python /usr/bin/python2.6
+%else
+%define python python
+%define __python /usr/bin/python
+%endif
+%{!?_python_sitelib: %define _python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+
+Name:           cubicweb-blog
+Version:        1.9.7
+Release:        logilab.1%{?dist}
+Summary:        blogging component for the CubicWeb framework
+Group:          Applications/Internet
+License:        LGPL
+Source0:        cubicweb-blog-%{version}.tar.gz
+
+BuildArch:      noarch
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
+
+BuildRequires:  %{python} %{python}-setuptools
+Requires:       cubicweb >= 3.10.0
+
+%description
+blogging component for the CubicWeb framework
+
+%prep
+%setup -q -n cubicweb-blog-%{version}
+%if 0%{?el5}
+# change the python version in shebangs
+find . -name '*.py' -type f -print0 |  xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
+%endif
+
+%install
+NO_SETUPTOOLS=1 %{__python} setup.py --quiet install --no-compile --prefix=%{_prefix} --root="$RPM_BUILD_ROOT"
+# remove generated .egg-info file
+rm -rf $RPM_BUILD_ROOT/usr/lib/python*
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-, root, root)
+/*
--- a/debian/changelog	Thu Mar 21 15:40:29 2013 +0100
+++ b/debian/changelog	Mon Aug 05 11:15:44 2013 +0200
@@ -1,3 +1,9 @@
+cubicweb-blog (1.9.7-1) unstable; urgency=low
+
+  * new upstream release
+
+ -- David Douard <david.douard@logilab.fr>  Fri, 02 Aug 2013 16:41:44 +0200
+
 cubicweb-blog (1.9.6-1) unstable; urgency=low
 
   * new upstream release