[pkg] prepare 4.0.0 draft
authorDavid Douard <david.douard@logilab.fr>
Tue, 13 Jan 2015 14:19:00 +0100
changeset 1783 e3aad84adf03
parent 1782 69394bafe4bd
[pkg] prepare 4.0.0
__pkginfo__.py
debian/control
--- a/__pkginfo__.py	Fri Nov 21 20:07:15 2014 +0100
+++ b/__pkginfo__.py	Tue Jan 13 14:19:00 2015 +0100
@@ -4,7 +4,7 @@
 modname = 'apycotlib'
 distname = 'apycot'
 
-numversion = (3, 2, 0)
+numversion = (4, 0, 0)
 version = '.'.join(str(num) for num in numversion)
 
 license = 'GPL'
@@ -22,7 +22,8 @@
 __depends__ = {'cubicweb': '>= 3.19.0',
                'cubicweb-vcsfile': '>= 2',
                'cubicweb-file': None,
-               'cubicweb-narval': '>= 4.1',
+               'cubicweb-narval': '>= 4.2',
+               'python-hglib': '>= 1.4',
                'Pygments': None,
                'lxml': None,
                'logilab-packaging': '>= 1.0.0',
@@ -31,6 +32,8 @@
                   'cubicweb-nosylist': '>= 0.5.0',
                   'cubicweb-jqplot': '>= 0.1.2',
                   'coverage': None,
+                  'pylint': None,
+                  'coverage': None,
                   }
 
 # packaging ###
--- a/debian/control	Fri Nov 21 20:07:15 2014 +0100
+++ b/debian/control	Tue Jan 13 14:19:00 2015 +0100
@@ -15,7 +15,7 @@
  cubicweb-common (>= 3.19),
  cubicweb-vcsfile (>= 2),
  cubicweb-file (>= 1.14),
- cubicweb-narval (>= 4.1),
+ cubicweb-narval (>= 4.2),
  python-pygments,
  ${misc:Depends},
  ${python:Depends},
@@ -32,10 +32,9 @@
 Package: narval-apycot
 Architecture: all
 Depends:
- narval-bot (>= 4.1),
+ narval-bot (>= 4.2),
  python-unittest2 | python (>= 2.7),
  python-lxml,
- mercurial (>= 2.2),
  python-logilab-packaging,
  ${misc:Depends},
  ${python:Depends},