Silence cubicweb 3.15 deprecation warning
authorJulien Cristau <julien.cristau@logilab.fr>
Wed, 11 Jun 2014 15:51:48 +0200
changeset 28 15f43e5c1ffe
parent 27 dea71167c553
child 29 d03acdfd9327
Silence cubicweb 3.15 deprecation warning
__pkginfo__.py
cubicweb-activitystream.spec
debian/control
views.py
--- a/__pkginfo__.py	Wed Jun 11 15:50:44 2014 +0200
+++ b/__pkginfo__.py	Wed Jun 11 15:51:48 2014 +0200
@@ -19,7 +19,7 @@
     'Programming Language :: JavaScript',
     ]
 
-__depends__ =  {'cubicweb': '>= 3.10.8'}
+__depends__ =  {'cubicweb': '>= 3.15'}
 __recommends__ = {}
 
 
--- a/cubicweb-activitystream.spec	Wed Jun 11 15:50:44 2014 +0200
+++ b/cubicweb-activitystream.spec	Wed Jun 11 15:51:48 2014 +0200
@@ -20,7 +20,7 @@
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 
 BuildRequires:  %{python} %{python}-setuptools
-Requires:       cubicweb >= 3.10.8
+Requires:       cubicweb >= 3.15
 
 %description
 activity streams component for the CubicWeb framework
--- a/debian/control	Wed Jun 11 15:50:44 2014 +0200
+++ b/debian/control	Wed Jun 11 15:51:48 2014 +0200
@@ -9,7 +9,7 @@
 
 Package: cubicweb-activitystream
 Architecture: all
-Depends: cubicweb-common (>= 3.10.8)
+Depends: cubicweb-common (>= 3.15)
 Description: activity streams
  CubicWeb is a semantic web application framework.
  .
--- a/views.py	Wed Jun 11 15:50:44 2014 +0200
+++ b/views.py	Wed Jun 11 15:51:48 2014 +0200
@@ -1,5 +1,5 @@
 from logilab.mtconverter import xml_escape
-from cubicweb.selectors import is_instance, adaptable
+from cubicweb.predicates import is_instance, adaptable
 from cubicweb.view import EntityView
 
 class AStreamView(EntityView):