Allow rql to work with yapps 2.2.0 which is properly released on pypi, and remove the custom dependency link for it.
authorChristophe de Vienne <christophe@unlish.com>
Wed, 04 Jun 2014 22:30:35 +0200
changeset 732 be1d0045f2e3
parent 731 4239093674fe
child 733 843843e76fac
Allow rql to work with yapps 2.2.0 which is properly released on pypi, and remove the custom dependency link for it. Closes #124962 Closes #245540
__pkginfo__.py
--- a/__pkginfo__.py	Wed Apr 23 13:59:02 2014 +0200
+++ b/__pkginfo__.py	Wed Jun 04 22:30:35 2014 +0200
@@ -82,11 +82,6 @@
 install_requires = [
     'logilab-common >= 0.47.0',
     'logilab-database >= 1.6.0',
-    'yapps == 2.1.1', # XXX to ensure we don't use the broken pypi version
+    'yapps >= 2.2.0', # XXX to ensure we don't use the broken pypi version
     'logilab-constraint >= 0.5.0', # fallback if the gecode compiled module is missing
     ]
-
-# links to download yapps2 package that is not (yet) registered in pypi
-dependency_links = [
-    "http://download.logilab.org/pub/yapps/yapps2-2.1.1.zip#egg=yapps-2.1.1",
-    ]