[pkg] Add dependency on six
authorJulien Cristau <julien.cristau@logilab.fr>
Mon, 01 Dec 2014 17:14:15 +0100
changeset 745 8e53b305c77b
parent 744 f66ac8ee424e
child 746 2c51ddf1fce5
[pkg] Add dependency on six
__pkginfo__.py
debian/control
python-rql.spec
--- a/__pkginfo__.py	Sun Jul 20 12:52:15 2014 +0200
+++ b/__pkginfo__.py	Mon Dec 01 17:14:15 2014 +0100
@@ -84,4 +84,5 @@
     'logilab-database >= 1.6.0',
     'yapps >= 2.2.0', # XXX to ensure we don't use the broken pypi version
     'logilab-constraint >= 0.5.0', # fallback if the gecode compiled module is missing
+    'six >= 1.4.0',
     ]
--- a/debian/control	Sun Jul 20 12:52:15 2014 +0200
+++ b/debian/control	Mon Dec 01 17:14:15 2014 +0100
@@ -18,7 +18,8 @@
 Depends: ${python:Depends}, ${misc:Depends}, ${shlibs:Depends},
          python-logilab-common (>= 0.35.3-1),
          yapps2-runtime,
-         python-logilab-database (>= 1.6.0)
+         python-logilab-database (>= 1.6.0),
+         python-six (>= 1.4.0),
 Conflicts: cubicweb-common (<= 3.13.9)
 Provides: ${python:Provides}
 Suggests: python-pygments
--- a/python-rql.spec	Sun Jul 20 12:52:15 2014 +0200
+++ b/python-rql.spec	Mon Dec 01 17:14:15 2014 +0100
@@ -25,6 +25,7 @@
 Requires:       %{python}-logilab-database >= 1.6.0
 Requires:       %{python}-yapps2 >= 2.1.1
 Requires:       %{python}-logilab-constraint >= 0.5.0
+Requires:       %{python}-six >= 1.4.0
 
 
 %description