[pkg] don't try to build the python3 package if the python3 version is too old 0.34.0 centos/0.34.0-1 debian/0.34.0-1
authorJulien Cristau <julien.cristau@logilab.fr>
Mon, 04 Jan 2016 17:03:05 +0100
changeset 794 8411efb08f71
parent 793 b8465dbebf6f
child 795 aa6c753b0a4e
[pkg] don't try to build the python3 package if the python3 version is too old
debian/rules
--- a/debian/rules	Mon Jan 04 16:30:42 2016 +0100
+++ b/debian/rules	Mon Jan 04 17:03:05 2016 +0100
@@ -2,8 +2,12 @@
 
 export RQL_FORCE_GECODE=1
 
+ifeq (,$(shell py3versions -r 2>/dev/null))
+    py3k = -Npython3-rql
+endif
+
 %:
-	dh $@ --with python2,python3 --buildsystem pybuild
+	dh $@ --with python2,python3 --buildsystem pybuild $(py3k)
 
 override_dh_auto_build:
 	dh_auto_build