backport stable
authorFlorent Cayre <florent.cayre@logilab.fr>
Wed, 10 Apr 2013 14:06:10 +0200
changeset 708 0c6345ca92b1
parent 704 47cce2221f93 (current diff)
parent 707 cb978d851ad1 (diff)
child 719 4e574315c418
backport stable
--- a/.hgtags	Mon Apr 08 17:11:26 2013 +0200
+++ b/.hgtags	Wed Apr 10 14:06:10 2013 +0200
@@ -75,3 +75,6 @@
 543fe6d74b492f198d8bf7dc5e90ff3e3276fa8b rql-debian-version-0.31.1-1
 55af3a14cc29dedab697deabfc7602e140ac3dd8 rql-version-0.31.2
 513a02cce3c22ea14a13f878ccee21c9540a26da rql-debian-version-0.31.2-1
+2ce80cbd45f769b8119a2d37b4fe784e9ad9d291 rql-version-0.31.3
+f388ee9b713d90ba1d4a9fe4264562080bdfb696 rql-debian-version-0.31.3-1
+496945a4ed23f645f2e4847ebf60c84b8f27d338 rql-centos-version-0.31.3-1
--- a/__pkginfo__.py	Mon Apr 08 17:11:26 2013 +0200
+++ b/__pkginfo__.py	Wed Apr 10 14:06:10 2013 +0200
@@ -20,7 +20,7 @@
 __docformat__ = "restructuredtext en"
 
 modname = "rql"
-numversion = (0, 31, 2)
+numversion = (0, 31, 3)
 version = '.'.join(str(num) for num in numversion)
 
 license = 'LGPL'
@@ -83,7 +83,7 @@
     'logilab-common >= 0.47.0',
     'logilab-database >= 1.6.0',
     'yapps == 2.1.1', # XXX to ensure we don't use the broken pypi version
-    'constraint >= 0.5.0', # fallback if the gecode compiled module is missing
+    'logilab-constraint >= 0.5.0', # fallback if the gecode compiled module is missing
     ]
 
 # links to download yapps2 package that is not (yet) registered in pypi
--- a/debian/changelog	Mon Apr 08 17:11:26 2013 +0200
+++ b/debian/changelog	Wed Apr 10 14:06:10 2013 +0200
@@ -1,3 +1,9 @@
+rql (0.31.3-1) unstable; urgency=low
+
+  * new upstream release
+
+ -- Aurélien Campéas <aurelien.campeas@logilab.fr>  Wed, 30 Jan 2013 18:54:00 +0100
+
 rql (0.31.2-1) unstable; urgency=low
 
   * new upstream release
--- a/doc/.templates/layout.html	Mon Apr 08 17:11:26 2013 +0200
+++ b/doc/.templates/layout.html	Wed Apr 10 14:06:10 2013 +0200
@@ -4,7 +4,7 @@
 {%- endblock %}
 {%- set reldelim1 = reldelim1 is not defined and ' &raquo;' or reldelim1 %}
 {%- set reldelim2 = reldelim2 is not defined and ' |' or reldelim2 %}
-{%- macro relbar %}
+{%- macro relbar() %}
     <div class="related">
       <h3>Navigation</h3>
       <ul>
@@ -24,7 +24,7 @@
       </ul>
     </div>
 {%- endmacro %}
-{%- macro sidebar %}
+{%- macro sidebar() %}
       {%- if builder != 'htmlhelp' %}
       <div class="sphinxsidebar">
         <div class="sphinxsidebarwrapper">
--- a/python-rql.spec	Mon Apr 08 17:11:26 2013 +0200
+++ b/python-rql.spec	Wed Apr 10 14:06:10 2013 +0200
@@ -8,7 +8,7 @@
 %endif
 
 Name:           %{python}-rql
-Version:        0.31.2
+Version:        0.31.3
 Release:        logilab.1%{?dist}
 Summary:        relationship query language (RQL) utilities
 
@@ -16,12 +16,15 @@
 License:        LGPLv2+
 URL:            http://www.logilab.org/project/rql
 Source0:        http://download.logilab.org/pub/rql/rql-%{version}.tar.gz
-BuildArch:      noarch
 BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
 
 BuildRequires:  %{python}-devel
 BuildRequires:  gecode-devel
-Requires:       %{python}, %{python}-logilab-common >= 0.47.0, %{python}-logilab-database >= 1.6.0, %{python}-yapps2 >= 2.1.1, %{python}-logilab-constraint >= 0.5.0
+Requires:       %{python}
+Requires:       %{python}-logilab-common >= 0.47.0
+Requires:       %{python}-logilab-database >= 1.6.0
+Requires:       %{python}-yapps2 >= 2.1.1
+Requires:       %{python}-logilab-constraint >= 0.5.0
 
 
 %description