debian/rules
author Julien Cristau <julien.cristau@logilab.fr>
Mon, 04 Jan 2016 17:03:05 +0100
changeset 794 8411efb08f71
parent 793 b8465dbebf6f
child 862 942ef0731f4c
permissions -rwxr-xr-x
[pkg] don't try to build the python3 package if the python3 version is too old

#!/usr/bin/make -f

export RQL_FORCE_GECODE=1

ifeq (,$(shell py3versions -r 2>/dev/null))
    py3k = -Npython3-rql
endif

%:
	dh $@ --with python2,python3 --buildsystem pybuild $(py3k)

override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C doc html

override_dh_auto_clean:
	dh_auto_clean
	$(MAKE) -C doc clean

override_dh_auto_test:
	# nothing

# prevent dh_python2 from generating bogus deps on python-yapps (nonexistent)
# or python-logilab-constraint (unnecessary with gecode)
override_dh_python2:
	dh_python2 --no-guessing-deps

override_dh_python3:
	dh_python3 --no-guessing-deps