debian/control
author Alexandre Fayolle <alexandre.fayolle@logilab.fr>
Mon, 22 May 2006 12:38:25 +0200
changeset 1 b9b031063093
parent 0 7710b138d4eb
permissions -rw-r--r--
packaging updates

Source: oobrother
Section: python
Priority: optional
Maintainer: Adrien Di Mascio <Adrien.DiMascio@logilab.fr> 
Uploaders: Alexandre Fayolle <afayolle@debian.org>
Build-Depends: debhelper (>= 5.0.0), python2.3-dev, python
Standards-Version: 3.7.2

Package: oobrother
Architecture: all
Recommends: pylint  (>= 0.5), cvs|svn, vte
Depends: python (>= 2.3), python (<< 2.4), python2.3-oobrother (>= ${Source-Version}), oobrother-common
Description: customizable filesystem browser, designed to help python developers [dummy package]
 OoBrother is a pure-python graphical filesystem browser,
 mainly designed to help python developers.
 Among other features, OoObrother :
 - can be used as a speedbar (open each files with emacsclient)
 - provides VCS facilities
 - helps Debian package creations
 - launches unittests
 - checks modules and packages with pylint and pychecker
 .
 The most important thing is that you can easily customize OoBrother
 with your own plugins.
 .
 This package is an empty dummy package that always depends on a package built
 for Debian's default Python version.
 .
 Homepage: http://www.logilab.org/projects/oobrother

Package: oobrother-common
Architecture: all
Description: shared data for the oobrother package
 OoBrother is a pure-python graphical filesystem browser,
 mainly designed to help python developers.
 Among other features, OoObrother :
 - can be used as a speedbar (open each files with emacsclient)
 - provides VCS facilities
 - helps Debian package creations
 - launches unittests
 - checks modules and packages with pylint and pychecker
 .
 The most important thing is that you can easily customize OoBrother
 with your own plugins.
 .
 This package provides files shared by oobrother across different python
 versions:
  * Shared data
 .
 Homepage: http://www.logilab.org/projects/oobrother

Package: oobrother-test
Architecture: all
Depends: oobrother (= ${Source-Version}) | python2.3-oobrother (= ${Source-Version})
Description: oobrother's test files
 This package contains test files shared by the oobrother package. It
 isn't necessary to install this package unless you want to execute or
 look at the tests.

Package: python2.3-oobrother
Architecture: all
Depends: python2.3, python2.3-logilab-common (>= 0.5.0), python2.3-devtools, python2.3-gtk2, python2.3-pigg, python2.3-glade2, oobrother-common (>= ${Source-Version})
Recommends: python2.3-pylint  (>= 0.5), cvs|svn, python2.3-vte
Description: customizable filesystem browser, designed to help python developers [built for python2.3]
 OoBrother is a pure-python graphical filesystem browser,
 mainly designed to help python developers.
 Among other features, OoObrother :
 - can be used as a speedbar (open each files with emacsclient)
 - provides VCS facilities
 - helps Debian package creations
 - launches unittests
 - checks modules and packages with pylint and pychecker
 .
 The most important thing is that you can easily customize OoBrother
 with your own plugins.
 .
 This package is built with Python 2.3.
 .
 Homepage: http://www.logilab.org/projects/oobrother